手機版
你好,游客 登錄 注冊
背景:
閱讀新聞

arm-linux-gcc-4.5.1安裝方法

[日期:2020-01-07] 來源:Linux社區  作者:mfyfymeng [字體: ]

寫在前面

之前寫了一篇arm-linux-gcc-5.4.0的安裝方法,但是后來發現5.4.0這個版本可能有些太新了,所以又找了這個4.5.1版本(低版本),由FriendlyARM(友善之臂)提供,下面是具體安裝步驟。

安裝步驟

下載arm-linux-gcc-4.5.1安裝包

這里提供一個百度云鏈接:

鏈接: https://pan.baidu.com/s/1e40tMS4lme1H9A6KF9ylpQ 提取碼: 見本文評論部分

解壓

最好在/usr/local/下新建一個文件夾/arm,然后再把安裝包解壓到/arm下,要記住解壓的這個路徑,之后添加環境變量時要用到。用下面命令解壓
sudo tar -zxvf arm-linux-gcc-4.5.1... .tgz -C /usr/local/arm/

解壓之后會發現在/usr/local/arm路徑下已經有了/opt文件夾了,/opt文件夾里面還嵌套著幾層文件夾,路徑很長,不方便記憶及使用,不妨去掉幾層路徑,只保留/4.5.1這層。于是將文件夾/4.5.1復制到/usr/local/arm下
sudo cp -r /4.5.1 /usr/local/arm

此時,把/usr/local/arm下的/opt刪除,只保留/4.5.1這個有用的即可,于是,編譯器的安裝包的路徑為/usr/local/arm/4.5.1

添加環境變量
sudo vi /etc/environment

在最后添加下面這句
:usr/local/arm/4.5.1/bin/

更新
source /etc/environment

然后用下面這句查看是否添加成功
echo $PATH

添加庫

目前為止,即使添加并更新了環境變量,也不一定能夠正常使用。因為此時還是和x86存在一定的關系,還必須使用x86提供的一些庫,才能讓這個交叉編譯器運行起來。要想運行這個交叉編譯器,必須要有32位庫的支持,然而,64位的機器默認是沒有32位庫的,所以要在64位機器上添加32位庫。用下面這兩條語句添加
sudo apt-get install libc6:i386
sudo apt-get install lib32z1

檢查是否安裝成功
arm-linux-gcc -v

Linux公社的RSS地址http://www.okbuvi.live/rssFeed.aspx

本文永久更新鏈接地址http://www.okbuvi.live/Linux/2020-01/161954.htm

linux
相關資訊       arm-linux-gcc 
本文評論   查看全部評論 (1)
表情: 表情 姓名: 字數

       

評論聲明
  • 尊重網上道德,遵守中華人民共和國的各項有關法律法規
  • 承擔一切因您的行為而直接或間接導致的民事或刑事法律責任
  • 本站管理人員有權保留或刪除其管轄留言中的任意內容
  • 本站有權在網站內轉載或引用您的評論
  • 參與本評論即表明您已經閱讀并接受上述條款
第 1 樓
* Linux會員 發表于 2020/1/7 15:00:03
提取碼: p532
海口彩票论坛